Skip to content

Ubuntu com Netbeans Java e C

Boa noite,

Hoje pretendia instalar o netbeans 6.5.1 no Ubuntu 64 bits, baixei a versão que eu queria (C/C++) no site do netbeans. Tentava instalar o netbeans com o comando:

$ ./netbeans-6.5.1-ml-cpp-linux.sh

(PS: Tornei o mesmo executavel antes, com o comando $ chmod +x netbeans-6.5.1-ml-cpp-linux.sh)

Recebia a seguinte resposta:

[email protected]:~/Desktop$ ./netbeans-6.5.1-ml-cpp-linux.sh
Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Running the installer wizard...
[email protected]:~/Desktop$

Porém a parte grafíca não acontecia. Fui olhar o log da seguinte maneira:

$ sh netbeans-6.5.1-ml-cpp-linux.sh --verbose --output out.txt

Analisando o arquivo out.txt pude ver o seguinte erro:

[2009-04-27 20:56:18.173]: at org.netbeans.installer.Installer.main(Installer.java:78)
[2009-04-27 20:56:18.174]: ... show message dialog
[2009-04-27 20:56:18.174]: title: Critical Error
[2009-04-27 20:56:18.174]: message: An unexpected exception happened in thread main
[2009-04-27 20:56:18.174]:
[2009-04-27 20:56:18.174]: Exception:
[2009-04-27 20:56:18.174]: java.lang.NoClassDefFoundError:
[2009-04-27 20:56:18.175]: Could not initialize class java.awt.Toolkit

Infelizmente não sabia como corrigi-lo. Pesquisei um pouco e não achei nada que funcionasse. Então tive a brilhante idéia de instalar pelo synaptic. Instalei o netbeans que estava lá, tudo ocorreu normalmente. Executei o mesmo e fui criar um novo projeto, me deparo que a versão instalada era a para Java. Me decepcionei, afinal precisava mesmo da versão para C/C++. Quando fiz a instalação pelo synaptic percebi que existiam muitas dependencias, tentei instalar novamente a versão para C e vua-la. Consegui instalar a mesma. (Meio na gambiarra eu sei, afinal fiquei com 2 versões de netbeans uma para C e outra para Java, mas sem problemas já que eu utilizo as duas.)

Então caso você queira instalar a versão para C/C++, instale a versão de Java, ou suas dependencias somente e em seguida instale o para C/C++ que tudo vai ocorrer bem.

Ah, para um melhor entendimento editei o menu (Botao direito sobre Applications - edit menu), ele é muito intuitivo então não vou entrar em mais detalhes. Mas no mesmo editei os Netbeans 6.5 e 6.5.1 para Netbeans 6.5 (Java) e Netbeans 6.5.1 (C/C++). Assim não corro o problema de esquecer e abrir a versão errada perdendo tempo.

Espero que essa gambiarra dica ajude vocês.

Abraços,
Matheus

PS: Se alguem tiver a solução decente para conseguir instalar o Netbeans me avise que eu posto aqui. Ou caso eu descubra, postarei também.

Published inAprendendoCLinuxSoftware Livre

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.